My audit logs are stored in a database and the date/time format is as follows: Input (in Database) 9/16/2012 12:00:00 AM

I set the date time format for the field in Securonix as MM/dd/yyyy HH:mm:ss a However, I keep getting errors that the date/time format is incorrect. What am I doing wrong?

asked 01 Feb '13, 01:41

ted_m21's gravatar image

ted_m21
1112
accept rate: 0%


You need to specify the format in the SQL query itself if you want date/time to be retrieved in a specific format.

SELECT *, DATE_FORMAT(createdate, "%m-%d-%y") AS date FROM users;

This is the way you need to specify/format the date/time in the sql query and it should match the data/time format configured for the data/time fields/attributes.

link

answered 01 Feb '13, 01:44

jake's gravatar image

jake
1
accept rate: 0%

You can also take a look at the temporary file that gets created in the import/in folder. This is generated prior to importing the data into Securonix.

link

answered 01 Feb '13, 01:45

mahesh's gravatar image

mahesh
111
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×7
×4
×2
×2

Asked: 01 Feb '13, 01:41

Seen: 1,322 times

Last updated: 01 Feb '13, 01:45